Welcome to Vifm Q&A, where you can ask questions about Vifm usage. Registration is optional, anonymous posts are moderated. GitHub or Google logins are enabled.
0 votes
in vifm by

Hi,
I use gnome-terminal. Settings are

TERM = xterm-256color
colorscheme  : Gruvbox-dark.

and everything is Ok with vifm (colorscheme = Default)

Then I connect to a VM (kvm/qemu) via ssh and install vifm on it (colorScheme = Default).
On first run, vifm colors are Ok, same as the host (black background), in both panes.

On next runs, only the active pane shows correct background, the other pane has a light background, with underlines.

Any ideas ?

Thanks

2 Answers

0 votes
by
selected by
 
Best answer

Hello,

it's a bug in 0.10.1 in writing Default colorsccheme to a file. Open $VIFM/colors/Default.vifm and remove the line with OtherWin (or just cterm= part of the line).

by

Ok, thanks.
Just it's not OtherLine, but OtherWin !
It works fine, now.

by

Right, OtherWin. It was middle of the night :-)

by

in windows system no file Default.vifm, where can i find OtherWin
I'm find directory is "C:\Users\"YouUserName"\AppData\Roaming\Vifm\colors\Default.vifm"

by

Alex, you should be able to run :e $VIFM/colors/Default.vifm inside Vifm to open the file. That's easier than navigating there manually.

0 votes
by

I solved it by adding highlight clear to vifmrc.

If you would like to make a bug report or feature request consider using GitHub, SourceForge or e-mail. Posting such things here is acceptable, but this is not a perfect place for them.
...